Feature #2801

Does our ANSYS reader need an update?

Added by Kathleen Biagas 6 months ago. Updated 6 months ago.

Status:Resolved Start:04/06/2017
Priority:Normal Due date:
Assigned to:Mark Miller % Done:

0%

Category:-
Target version:2.13.0 Estimated time:4.00 hours
Found in Version:2.12.1 OS:All
Impact:3 - Medium Support Group:Any
Expected Use:3 - Occasional

Description

We had a customer email the users list with the attached file that VisIt cannot read parse correctly.
It is supposed to be compatible with ANSYS ADPL.

I stepped through with the debugger on windows, looking at how the ansys reader parses the nblock lines and first line of coordinate values:

nblock,3
(1i9,3e21.13e3)
1 9.1666666666667E+003 9.1666666666667E+003 9.1666666666667E+003

Either the reader isn't parsing the values correctly, or there is something wrong with the data file.

I could not find a file-format specification online to verify if the problem is with the data or the reader.

(BTW< reading on Linux yields same results)

cubeF.inp (1.1 MB) Kathleen Biagas, 04/06/2017 02:26 pm

History

Updated by Eric Brugger 6 months ago

  • Status changed from New to Pending
  • Assigned to set to Mark Miller
  • Target version set to 2.13.0

Updated by Mark Miller 6 months ago

  • Status changed from Pending to Resolved
  • Estimated time set to 4.00

There are a few different issues effecting behavior here not the least of which is some confusing ANSYS file format documentation where the NBLOCK directive and format string are described. See avtANSYSFileFormat.C::Interpret() method comments for details. Short story, most ANSYS files use a standard method for NBLOCK data and I think newer software has tried to optimize it a bit to either avoid unnecessary whitespace columns in ascii files or to faithfully encode field counts and this has lead to challenges in our ansys reader for newer ansys data files.

I made a correction which reads all our existing files and reads the newer file.

Also available in: Atom PDF